Inbound Call Disruption
Incident Report for SpecTronics UK
Resolved
No further reports have been received, and we are satisfied that this has been fully resolved.

If you are still experiencing any errors with your service please email support@spectronics.co.uk
Posted 8 months ago. Jun 26, 2018 - 17:26 BST
Monitoring
Following work completed by our engineers, service has returned to normal.

This status will be left in a monitoring state. Please accept our sincere apologies for the inconvenience caused.
Posted 8 months ago. Jun 26, 2018 - 11:19 BST
Update
While we are seeing call behaviour return to normal, we are performing emergency maintenance to stablise the service.

We apologise for the inconvenience caused.
Posted 8 months ago. Jun 26, 2018 - 11:09 BST
Investigating
We have identified a network issue that will be causing inbound calls to intermittently fail.

We are working to resolve this, and an update will be posted by 11:15 with further information.

Please accept our apologies for the inconvenience caused.
Posted 8 months ago. Jun 26, 2018 - 10:46 BST
This incident affected: Voice Services - Hosted VoIP (Hosted VoIP - Single User, Hosted VoIP - Multi User).