Inbound Call Failures
Incident Report for SpecTronics UK
Resolved
No further reports of this incident have been received, and we are satisfied that this is now resolved.

If you are still experiencing issues with your service please contact our support team on 03333 444 114 or email support@spectronics.co.uk

Please accept our apologies for any inconvenience this may have caused.
Posted over 1 year ago. Apr 04, 2018 - 17:03 BST
Monitoring
We have received confirmation that this incident is now fully resolved. This status will be left in a monitoring state as a precautionary measure.

If you are still experiencing issues with your service please contact our support team on 03333444114 or support@spectronics.co.uk

We apologise for any inconvenience this may have caused.
Posted over 1 year ago. Apr 04, 2018 - 16:00 BST
Identified
Our upstream supplier has identified the cause of the incident and is implementing an emergency change to resolve it. Customers should see service returning to normal.

Please accept our apologies for the inconvenience caused. A further update will be post by 15:45.
Posted over 1 year ago. Apr 04, 2018 - 15:25 BST
Update
This incident is still under investigation with our upstream suppliers. We have not been provided an estimated resolution time at this stage.

We apologise for any inconvenience this may cause. This status will be updated by 15:45 with further information.
Posted over 1 year ago. Apr 04, 2018 - 15:19 BST
Investigating
We are currently investigating reports of call failures to a subset of numbers. This appears to be a fault on an upstream supplier's network, and we are working closely with them to resolve it.

We apologise for any inconvenience this may cause. This status will be updated with further information by 15:15
Posted over 1 year ago. Apr 04, 2018 - 14:50 BST