Internal Call Failures
Incident Report for SpecTronics UK
Resolved
A fix has now been implemented. We will continue to monitor the system over the rest of the day.
Posted Nov 25, 2019 - 12:28 GMT
Investigating
We are currently unable to dial or receive calls to or from our office numbers. While we work to resolve this please get in touch using the contact email addresses below:

For General Queries: hello@spectronics.co.uk
For Technical Support: support@spectronics.co.uk

We hope to have this resolved very soon and will keep this status updated as updates become available.
Posted Nov 25, 2019 - 10:58 GMT
This incident affected: Support Team Systems (Phone).