Support Team Unavailable via Phone
Incident Report for SpecTronics UK
Resolved
This incident has now been resolved and our support phone lines open.

Please accept our apologies for any inconvenience caused.
Posted about 1 month ago. Aug 15, 2019 - 10:58 BST
Investigating
Our support team are currently unable to take support requests by phone. We are urgently working to resolve this and will post updates as available. In the meantime please forward all support requests to support@spectronics.co.uk

We apologize for any inconvenience.
Posted about 1 month ago. Aug 15, 2019 - 10:27 BST
This incident affected: SpecTronics Support Team Systems (Support Team - Phone).