Subset of inbound calls failing to connect
Incident Report for SpecTronics UK
Resolved
We have received no further reports of calls failing to connect and are confident that this has been fully resolved. If you have any questions or need any further assistance please contact our support team on support@spectronics.co.uk
Posted Jan 10, 2020 - 15:48 GMT
Monitoring
Our engineers have identified the issue and fixed the problem. All calls should now be connecting successfully. We will keep this status open to monitor the system.
Posted Jan 10, 2020 - 14:48 GMT
Investigating
We are aware of an issue affecting a small number of VoIP customers whereby some inbound calls are not connecting. We understand this is only affecting a small number of customers.

Our engineers are investigating this as a priority and an update will be posted as soon as we have further information.

We apologise for any inconvenience caused.
Posted Jan 10, 2020 - 14:08 GMT
This incident affected: Voice Services - Hosted VoIP (Hosted VoIP - Single User, Hosted VoIP - Multi User).