Inbound & Outbound call failures
Incident Report for SpecTronics UK
Resolved
We have had no further reports of call disruption since yesterday afternoon. We have kept the status open to monitor the system and have seen no further disruption.

Please accept our apologies for any inconvenience.
Posted Nov 15, 2019 - 14:40 GMT
Monitoring
BT have established the problem and service is recovering across the country.

We will monitor this over the next few hours.

Thank you for you patience.
Posted Nov 14, 2019 - 13:00 GMT
Identified
We have identified that the disruption to calls is linked to an issue identified by BT.
This is currently being investigated and we will update you when we receive more information.

Apologies for any inconvenience this is causing.
Posted Nov 14, 2019 - 12:23 GMT
Investigating
We are currently investigating issues with inbound & outbound call failures.

An update will be provided at 12:30pm. We apologies for the inconvenience caused.
Posted Nov 14, 2019 - 12:09 GMT
This incident affected: Voice Services - Hosted VoIP (Hosted VoIP - Single User, Hosted VoIP - Multi User).