Inbound and Outbound Call Failures
Incident Report for SpecTronics UK
Resolved
This incident has been resolved.
Posted over 1 year ago. Apr 24, 2018 - 16:26 BST
Update
Further analysis has confirmed that the issues being experienced by customers appear to be related to Google DNS cache issues.

Within our existing infrastructure we have our own public DNS. To help customers work around this incident, we would like to offer the use of our DNS free of charge. Customers currently using Google's public DNS may switch to use the following IPs:
109.224.233.174
109.224.233.190

Please feel free to share these details to other people who may be experiencing issues.

We will continue to update this status as further information comes available.
Posted over 1 year ago. Apr 24, 2018 - 13:39 BST
Update
We are continuing to investigate reports of this issue, however we are seeing fewer instances of call failures indicating that service may be returning to normal.

This status will be updated with further information by 13:45. We apologise for any inconvenience caused.
Posted over 1 year ago. Apr 24, 2018 - 13:17 BST
Update
We believe this issue to be related to wider DNS resolution issues with Google DNS.

We are continuing to investigate, and will update with status by 13:15 with further information.

Please accept our apologies for any inconvenience this may cause.
Posted over 1 year ago. Apr 24, 2018 - 12:50 BST
Investigating
We are currently investigating reports of inbound and outbound call failures on our hosted and trunk services.

We apologise for any inconvenience this causes. This status will be updated by 13:00 with further information.
Posted over 1 year ago. Apr 24, 2018 - 12:38 BST