Inbound Call Failures
Incident Report for SpecTronics UK
Resolved
We are confident that this matter is now fully resolved. A report will be posted on this status with information regarding the cause of the disruption as soon as it is available.

Please accept our apologies for the disruption.
Posted 10 months ago. Aug 21, 2018 - 16:16 BST
Monitoring
We are now seeing calls connect successfully, and are working with our upstream suppliers to identify the cause of the incident.

If you are still experiencing calls not connecting please contact our support team on support@spectronics.co.uk or 03333444114.

We apologise for any inconvenience caused by this incident.
Posted 10 months ago. Aug 21, 2018 - 15:52 BST
Investigating
We are currently investigating reports of inbound calls to a subset of phone numbers failing.

This will be affecting phone numbers ported to SpecTronics, as well as some numbers purchased directly from us.

We apologise for any inconvenience this may cause. This status will be updated with further information by 16:00.
Posted 10 months ago. Aug 21, 2018 - 15:34 BST
This incident affected: Voice Services - Hosted VoIP (Hosted VoIP - Single User, Hosted VoIP - Multi User).