Broadband Authentication Issues
Incident Report for SpecTronics UK
Resolved
This incident has been resolved.
Posted Jan 30, 2020 - 14:32 GMT
Investigating
We are continuing to investigate this issue.
Posted Jan 30, 2020 - 14:15 GMT
Monitoring
We have had confirmation from our upstream supplier that all services have been restored.

If you are still experiencing issues with your broadband service, please contact our support team on 03333 444 114 or support@spectronics.co.uk.

We sincerely apologise for the inconvenience & impact this has caused you.
Posted Jan 30, 2020 - 14:14 GMT
Identified
Our upstream supplier has confirmed broadband customers affected by the major incident connecting into one of their Manchester Data Centres are slowly recovering.

We expect full restoration to all services affected at 14:00.

A further update will be posted at 14:30.
Posted Jan 30, 2020 - 13:58 GMT
Update
We have been in direct contact with our suppliers who are still working to identify and resolve connectivity. We expect the next update before 14:00.

This is being treated as a critical priority.

We apologise for the inconvenience caused.
Posted Jan 30, 2020 - 13:01 GMT
Update
Our suppliers are continuing to investigate this as a critical priority. We will post a further update by 12:15.

We sincerely apologise for the inconvenience caused.
Posted Jan 30, 2020 - 11:51 GMT
Investigating
We have received reports from customers who are experiencing issues with their broadband services.

We are currently investigating the issue as a priority and a further update will be provided as soon as available.

We apologise for the inconvenience caused.
Posted Jan 30, 2020 - 11:20 GMT
This incident affected: Broadband/Connectivity Services (Broadband - ADSL, Broadband - FTTC).