Outbound Call Failures
Incident Report for SpecTronics UK
Resolved
We now understand the issue to have been fully resolved.
Posted over 1 year ago. Apr 19, 2018 - 08:47 BST
Monitoring
We are now seeing call volumes return to normal, and outbound calls connect successfully. We are continuing to monitor call volumes and identify the cause.

Please accept our apologies for any inconvenience caused.
Posted over 1 year ago. Apr 18, 2018 - 16:20 BST
Investigating
We are currently investigating reports of outbound call failures across our hosted VoIP, SIP trunk, and IAX customers.

We apologise for any inconvenience this may cause. This status will be updated with further information by 16:30.
Posted over 1 year ago. Apr 18, 2018 - 16:14 BST